• Compression issues, cylinder misfire, and low idle
  • Started by pacmanzx2
Compression issues, cylinder misfire, and low idle
on: December 14, 2010, 04:33:44 PM
« Last Edit: December 31, 1969, 04:00:00 PM by Guest »
ZX2 has been having low idle. Changed the pcv hose, improved but still idles low. Especially when engine is cold. Check the codes and got a PO303 and 304 cylinder misfire codes, although engine doesn't seem to be misfiring. It is also burning spark plug wires on cylinders 3 and 4. Thinking that there was too much voltage getting through I changed the coil, but no difference. Ran a compression check and 130 psi the first try, then 90 psi, and 60 psi. Once engine warmed up the readings increased.

Car almost didn't want to start today. What could be the problem? Are the cylinders really misfiring? Cause I think that would be something I would notice.


  • brawleyzx2
  • Junior Member
  • **

    • 63


    • 0
    • January 20, 2013, 09:51:05 PM
    • Brawley, CA
  • more
Re: Compression issues, cylinder misfire, and low idle
Reply #1 on: December 25, 2010, 12:13:10 AM
« Last Edit: December 31, 1969, 04:00:00 PM by Guest »
Have you tried the idle air control valve? That one did it for me one time. Also check the o2 sensor for proper operation


Re: Compression issues, cylinder misfire, and low idle
Reply #2 on: December 29, 2010, 08:09:51 AM
« Last Edit: December 31, 1969, 04:00:00 PM by Guest »
I disconnected the plug from the iac valve and the car shut off. If it were the o2 sensor wouldn't it throw a code?


  • brawleyzx2
  • Junior Member
  • **

    • 63


    • 0
    • January 20, 2013, 09:51:05 PM
    • Brawley, CA
  • more
Re: Compression issues, cylinder misfire, and low idle
Reply #3 on: December 29, 2010, 07:50:25 PM
« Last Edit: December 31, 1969, 04:00:00 PM by Guest »
When the IACV went bad it took a couple of month's before the check engine light came on. All the while  I had really cool sounding engine kind of like the top fuel dragsters at idle. Check the battery and alternators as well does not hurt to check the battery cables as well for corrosion


Re: Compression issues, cylinder misfire, and low idle
Reply #4 on: January 11, 2011, 02:59:19 PM
« Last Edit: December 31, 1969, 04:00:00 PM by Guest »
Have you tried to change your spark plugs? Mine set off a code for cylinder misfire. Didn't have compression problems though. My first thought would be change your spark plugs for misfire if you haven't. It might make a small difference. I doubt it though.  It sounds to me like jumped timing or a blown head gasket or maybe even the head.


Re: Compression issues, cylinder misfire, and low idle
Reply #5 on: April 13, 2011, 09:33:27 AM
« Last Edit: December 31, 1969, 04:00:00 PM by Guest »
Change the plugs, look for oil unusual wear etc. Notice ur car smoking or anything unusual?
MMI CAI, ZXTuner Header, 2.5" Stainless Tru Bendz, MSD Coil, Ford Racing Wires, TWM STS, SCT xcal3, Cam Gears W/ VCT Delete, Fiddy Flywheel, Spec Stg. 2 Clutch, UDP, 16" TSW, S/R Cluster, S/R Knob and Boot, 98 VC, Steering Wheel/Hub, VIS CF Hood